API_​RubberPolyCallbacks

Parameters of the polygon input operation.

    typedef struct {
        GSPtr     *rubberLineInfoProc;
        GSPtr     *get3DComponentProc;
        GSPtr     *addPolyNodeProc;
        GSPtr     *delPolyNodeProc;
    } API_RubberPolyCallbacks;

 

Members

rubberLineInfoProc
[in] Callback function for custom feedback drawing. See the RubberLineInfoProc.
get3DComponentProc API 14
[in] Callback function to query the 3D component. See the Get3DComponentProc.
addPolyNodeProc
[in] Callback function for custom feedback editing polygons. See the AddPolyNodeProc.
delPolyNodeProc
[in] Callback function for custom feedback editing polygons. See the DelPolyNodeProc.

 

Remarks

For the utilization of API_RubberPolyCallbacks see the APIIo_GetPolyID.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_GetPolyID, RubberLineInfoProc, Get3DComponentProc, AddPolyNodeProc, DelPolyNodeProc, API Types