API_​RuledShellData

This structure holds the Ruled Shell specific data of API_ShellType.

    typedef struct {
        API_Polygon             shellShape1;
        API_Tranmat             plane1;
        API_Polygon             shellShape2;
        API_Tranmat             plane2;
        API_ContourEdgeData     begShapeEdgeData;
        API_ContourEdgeData     endShapeEdgeData;
        API_ContourEdgeData     ruledEdgeDatas[2];
        API_MorphingRuleID      morphingRule;
        bool                    filler_1[4];
    } API_RuledShellData;

 

Members

shellShape1
Specification of the first profile polygon. The shape data arrays are held in the first API_ShellShapeData record of shellShapes in API_ElementMemo.
plane1
Plane of the first profile.
shellShape2
Specification of the second profile polygon. The shape data arrays are held in the second API_ShellShapeData record of shellShapes in API_ElementMemo..
plane2
Plane of the second profile.
begShapeEdgeData
Edge information for the starting plane of the shell.
endShapeEdgeData
Edge information for the end plane of the shell.
ruledEdgeDatas
Edge information for the edges connecting points of the starting and end plane.
morphingRule
Morphing method for shape generation: paired segments or smooth.

 

Remarks

For shell related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_ShellType
API_Polygon, API_Tranmat
API_ContourEdgeData, API_MorphingRuleID
API_ShellShapeData, API_ElementMemo
Element Manager, API Types