API_​RunType

Describes a continous monostyle piece – called run – of a paragraph.

    typedef struct {
        Int32              from;
        Int32              range;
        short              pen;
        unsigned short     faceBits;
        short              font;
        unsigned short     effectBits;
        double             size;
        double             filler_1[3];
    } API_RunType;

 

Members

from
The beginning byte offset of the run in the content.
range
The range of the run in byte offset.
pen
Pen attribute index.
faceBits
Style (face) of the run:

APIFace_Plain

Plain text

APIFace_Bold

Bold

APIFace_Italic

Italic

APIFace_Underline

Underline

font
Font attribute index.
effectBits
Effect on the run:
APIEffect_StrikeOut Strikethrough text
APIEffect_SuperScript Superscript
APIEffect_SubScript Subscript
APIEffect_Fractional Fractional text (not used)
APIEffect_Protected Protected text (autotext reference)  Featuring API 10
size
Character height in mm.

 

Remarks

From Archicad 9 you are able to create multistyle text or textual label. The textContent field of API_ElementMemo structure contains the content. By text or textual label element creating you can pass the content as a UniCode string (set charCode field of API_TextType structure to CC_UniCode and cast textContent field of API_ElementMemo to (unsigned short*)). In this case all offsets (from, range...) are character offset instead of byte offset. A run can not contain line end character. For more details examine Element Manager example project.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Elements.h

 

See Also

API_TabID, API_ParagraphType, API_RunType, API_TextType, API_LabelType, API_ElementMemo, API Types