API_​LayoutBook

Represents the Book settings.

    typedef struct {
        bool                                    flatNumbering;
        GS::UniString                           prefix;
        API_NumberingStyle                      numberingStyle;
        Int32                                   startAt;
        bool                                    useChangeOwnID;
        GS::UniString                           changePrefix;
        API_NumberingStyle                      changeNumberingStyle;
        GS::HashTable<API_Guid, GS::UniString>  customScheme;
        Int32                  filler_1[2];
    } API_LayoutBook;

 

Members

flatNumbering
Use flat Layout order or hierarchy (Tree view by Subset).
prefix
ID Prefix.
numberingStyle
ID appearance style.
startAt
Start numbering at.
useChangeOwnID
Use change ID or Number by Revisions.
changePrefix
ID prefix in Revisions.
changeNumberingStyle
ID appearance style in Revisions.
customScheme
Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.

 

Remarks

You are able to get Book Settings via APIDb_GetLayoutBookID function.

 

Requirements

Version: API 18 or later
Header: APIdefs_Database.h

 

See Also

APIDb_GetLayoutBookID, API Types