Represents a revision change.
typedef struct { GS::UniString id; GS::UniString description; GSTime lastModifiedTime; GS::UniString modifiedByUser; bool issued; bool archived; GS::HashTable<API_Guid, GS::UniString> customData; } API_RVMChange;
Members
- id
- Unique ID of the Change.
- description
- Short description of the Change.
- lastModifiedTime
- Last modified time of the Change.
- modifiedByUser
- TW user identifier (full name) who last modified the Change.
- issued
- Change in a document revision is in an issue or not.
- archived
- Change is archived or active.
- customData
- Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.
Remarks
You are able to get all changes via APIDb_GetRVMChangesID function, and get the custom scheme of changes via APIDb_GetRVMChangeCustomSchemeID function.
Requirements
- Version: API 18 or later
- Header: APIdefs_Database.h
See Also
APIDb_GetRVMChangesID, APIDb_GetRVMChangeCustomSchemeID, API Types