Represents a Document Revision.
typedef struct { API_Guid guid; GS::UniString id; GS::UniString finalId; short userId; API_RVMDocumentRevisionStatusID status; Int32 filler; API_RVMLayoutInfo layoutInfo; } API_RVMDocumentRevision;
Members
- guid
- GUID of the Document Revision.
- id
- ID of the Document Revision.
- finalId
- ID with optional suffix (- WIP) of the Document Revision.
- userId
- The member ID of the owner in TeamWork mode.
- status
- Status of the document revision (issued or opened).
- layoutInfo
- Layout meta data.
Remarks
You are able to get all document revisions via APIDb_GetRVMDocumentRevisionsID function.
Requirements
- Version: API 18 or later
- Header: APIdefs_Database.h