Represents layout meta data in API_RVMDocumentRevision.
typedef struct { GS::UniString id; API_DatabaseUnId dbId; GS::UniString name; GS::UniString masterLayoutName; double width; double height; GS::Array<GS::UniString> drawingScales; GS::UniString subsetId; GS::UniString subsetName; GS::HashTable<API_Guid, GS::UniString> customData; short teamworkOwner; short filler[3]; } API_RVMLayoutInfo;
Members
- id
- ID of the layout.
- dbId
- Database unique identifier. Valid only for opened issue.
- name
- Name of the layout.
- masterLayoutName
- Name of the master layout.
- width
- Width of the layout.
- height
- Height of the layout.
- drawingScales
- Array of the drawing scales.
- subsetId
- ID of the subset.
- subsetName
- Name of the subset.
- customData
- Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.
- teamworkOwner
- Teamwork owner of the layout.
Remarks
This structure contains layout meta data for API_RVMDocumentRevision.
Requirements
- Version: API 18 or later
- Header: APIdefs_Database.h