API_​SavePars_​Archive

Parameters to save the current project as archive file.

    typedef struct {
        bool      picturesInTIFF;
        bool      texturesOn;
        bool      backgroundPictOn;
        bool      propertiesOn;
        bool      libraryPartsOn;
        bool      filler_1;
        bool      filler_2;
        bool      filler_3;
        Int32     filler_4[8];
    } API_SavePars_Archive;

 

Members

picturesInTIFF
Save pict/bmp files for readable on both (Mac/Win) platforms
texturesOn
Include linked Textures while saving archive
backgroundPictOn
Include Background Picture while saving archive
propertiesOn
Include All Properties Library Parts while saving archive
libraryPartsOn
Include Full Library while saving archive

 

Remarks

For the utilization of this structure see the APIDo_SaveID automation function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

APIDo_SaveID, API Types