API_​SavePars_​Object

Contains the different options for saving an Archicad object, lamp, door, or window.

    typedef struct {
        API_ConvModID     libItMode;
        bool              removeLine;
        bool              saveSelOnly;
        bool              view2D;
        bool              isPlaceable;
        Int32             filler_2[8];
    } API_SavePars_Object;

 

Members

libItMode
The place where to put the GDL text/binary information (only when saving from the 3D view).
removeLine
Remove redundant lines (only when saving from the 3D view).
saveSelOnly
Save selection only when the file type is object file (only when saving from a 2D view).
view2D
Save 2D or 3D view (when the file type is object file).
isPlaceable 13
The library part is placeable.

 

Remarks

If you want to save the plan view of an element or the selected elements (this is controlled by the saveSelOnly field), then set view2D to true. In this case the type of the file (fileTypeID in API_FileSavePars should be set to APIFType_ObjectFile.

When you want to save the 3D view, then clear the view2D field. In this case the fileTypeID can be APIFType_ObjectFile, APIFType_DoorFile, or APIFType_WindowFile. The libItMode field controls whether the file should become an editable text or a non-editable binary file. The removeLine field effects only objects saved from the 3D view.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

API_ConvModID, API_FileSavePars,
API Types