API_​SavePars_​Picture

Contains the different options for saving pictures from Archicad.

    typedef struct {
        API_ColorDepthID     colorDepth;
        bool                 dithered;
        bool                 view2D;
        bool                 crop;
        bool                 keepSelectionHighlight;
        Int32                filler_2[8];
    } API_SavePars_Picture;

 

Members

colorDepth
The bit depth of the picture (see API_ColorDepthID).
dithered
dithered picture (if less than or equal to 256 colors or grays)
view2D
Save 2D or 3D view.
crop
Save picture with cropping to the current zoom (2D only).
keepSelectionHighlight
Save picture with keeping selection on.

 

Remarks

These options correspond to the different settings in the File/Save dialogs.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Automate.h

 

See Also

API_ColorDepthID, API_FileSavePars,
API Types