API_​SavePars_​PlanDump

Contains the different options for saving a plandump from Archicad.

    typedef struct {
        bool      elementsOn;
        bool      attributesOn;
        bool      propertiesOn;
        bool      filler_1;
        Int32     filler_2[9];
    } API_SavePars_PlanDump;

 

Members

elementsOn
Include all elements in plandump file.
attributesOn
Include all attributes in plandump file.
propertiesOn
Include properties in plandump file.

 

Remarks

These options correspond to the different settings in the File/Save dialogs.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

API_FileSavePars, API Types