API_​SectElemType

Describes an element in the section window.

    typedef struct {
        API_Elem_Head      head;
        API_ElemType       parentType;
        Int32              filler_1;
        API_Guid           parentGuid;
        Int32              filler_2[6];
        API_Guid           ownerGuid;
    } API_SectElemType;

 

Members

head
General element header.
parentType
Parent elem type.
parentGuid Changed in API 11
Parent elem GUID.
ownerGuid Featuring API 12
GUID of owner curtain wall it the parent is a curtain wall subelem (frame, panel, junction or accessory). APINULLGuid in all other cases.

 

Remarks

This structure represents elements in the section window, which originally were created in the 2D or 3D window, and are visible in the current section window.

New in API 26 From version 26 the type of the parentID member was changed into API_ElemType.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_ElemType, API_Element,
Element Manager, API Types