API_​SelectionInfo

Information about the current selection.

    typedef struct {
        API_SelTypeID     typeID;
        Int32             sel_nElem;
        Int32             sel_nElemEdit;
        Int32             filler_1[3];
        bool              filler_2[3];
        bool              multiStory;
        Int32             filler_3;
        API_Region        marquee;
    } API_SelectionInfo;

 

Members

typeID
The type of the selection. It can be one of the marquee type or element type selection.
sel_nElem
Number of selected elements.
sel_nElemEdit
Number of the currently selected elements, which are editable.
multiStory
The marquee selection is extended to all stories.
marquee
The parameters of the marquee selection region.
 

Remarks

This structure is used to determine the type and the parameters of the current selection. You can retrieve this information with the ACAPI_Selection_Get function.
To change the current marquee with ACAPI_Selection_SetMarquee, you should set the typeID, multiStory and marquee fields in the API_SelectionInfo parameter.
In case of marquee-type selection don’t forget to dispose the coords handle in the marquee region when you don’t need it any more.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Elements.h

 

See Also

API_SelTypeID, API_Region,
ACAPI_Selection_Get,
Selection Manager, API Types