Types of the selection.
typedef enum { API_SelEmpty = 0, API_SelElems, API_MarqueePoly, API_MarqueeHorBox, API_MarqueeRotBox } API_SelTypeID;
Remarks
This enum is used when you get information about the current selection. See the ACAPI_Selection_Get function.
There are two basic type of selection methods in Archicad:
- The selection may be controlled by individually selected elements.
- The other possibility is to rely on the marquee area.
The API_SelEmpty
identifier means that no selection is actually used in Archicad. The API_SelElems
identifier corresponds to the first method when elements are individually selected. Other values identify that the selection is done by some kind of marquee shape.
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Elements.h