API_​ServerApplicationInfo

Describes the current server application the add-on is running under.

    typedef struct {
        API_ApplicationTypeID     serverApplication;
        UInt16                    mainVersion;
        Int16                     releaseVersion;
        bool                      runningInBackground;
        Int32                     buildNum;
        GS::UniString             language;
        GS::UniString             partnerID;
    } API_ServerApplicationInfo;

 

Members

serverApplication
The server application (Archicad or the 3D Engine).
mainVersion
The main version of the server application.
releaseVersion
The sub- (release) version of the server application.
runningInBackground 4.3
The server application was started in background mode.
buildNum New in API 12
The build number of the server application (not for the 3D Engine)
language New in API 12
The language of the server application as a C string (not for the 3D Engine). For example it contains “INT” for the international version, “JPN” for the Japanese version.
21 From API 21 this field is in Unicode.
partnerID 21
When Archicad runs on an SSA license this field contains the internal identifier of the reseller.

 

Remarks

This is a read-only member of the API_EnvirParams structure, passed as a parameter to the CheckEnvironment function. It can be also obtained with the APIEnv_ApplicationID environment function.

From API 21 you shouldn’t call BNZeroMemory or memset on this structure.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Registration.h

 

See Also

API_EnvirParams
APIEnv_ApplicationID
CheckEnvironment
API Types