Describes an arc item in a symbol fill.
typedef struct { API_Coord begC; API_Coord origC; double angle; } API_SFill_Arc;
Members
- begC
- The beginning coordinate of the arc item in the symbol fill.
- origC
- The origin of the arc item in the symbol fill. The distance of the origin and the beginning coordinate defines the radius of the arc.
- angle
- The angle of the arc item in the symbol fill, measured CCW.
Remarks
The drawing below illustrates the meaning of the fields.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Attributes.h