API_​ShapePrimsParams

Shape primitive parameters.

    typedef struct {
        bool                    dontClip;
        bool                    allStories;
        Geometry::Polygon2D     *polygon;
    } API_ShapePrimsParams;

 

Members

dontClip Changed in API 14
Pass false to turn off clippings when exploding a drawing.
allStories Changed in API 14
Pass false to use the drawing only on the current story
polygon Changed in API 18
Set a pointer to Geometry::Polygon2D to set that as a clipping polygon for the drawing.

 

Remarks

Use the ACAPI_Element_ShapePrimsExt function to virtually draw the shape of an element.

 

Requirements

Version: API 14 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_ShapePrimsExt, API Types