API_​ShellBaseContourEdgeTypeID

Determines the type of the shell contour edge.

    typedef enum {
        APIShellBaseContour_Undefined,
        APIShellBaseContour_Ridge,
        APIShellBaseContour_Valley,
        APIShellBaseContour_Gable,
        APIShellBaseContour_Hip,
        APIShellBaseContour_Eaves,
        APIShellBaseContour_Peak,
        APIShellBaseContour_SideWall,
        APIShellBaseContour_EndWall,
        APIShellBaseContour_RTDome,
        APIShellBaseContour_RTHollow
    } API_ShellBaseContourEdgeTypeID;

 

Members

APIShellBaseContour_Undefined
The shell contour edge type is not set (default value).
APIShellBaseContour_Ridge
The shell contour edge type is Ridge.
APIShellBaseContour_Valley
The shell contour edge type is Valley.
APIShellBaseContour_Gable
The shell contour edge type is Gable.
APIShellBaseContour_Hip
The shell contour edge type is Hip.
APIShellBaseContour_Eaves
The shell contour edge type is Eaves.
APIShellBaseContour_Peak
The shell contour edge type is Peak.
APIShellBaseContour_SideWall
The shell contour edge type is Side Wall.
APIShellBaseContour_EndWall
The shell contour edge type is End Wall.
APIShellBaseContour_RTDome
The shell contour edge type is Roof Transition – Dome.
APIShellBaseContour_RTHollow
The shell contour edge type is Roof Transition – Hollow.

  

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_ShellType, API_ContourEdgeData
Element Manager, API Types