These values affect the connection type of Roof and Shell elements (see on the Model tab page of the Roof/Shell Settings dialog).
typedef enum { APIShellBaseCutBody_Editable, APIShellBaseCutBody_ContoursDown, APIShellBaseCutBody_PivotLinesDown, APIShellBaseCutBody_UpwardsExtrusion, APIShellBaseCutBody_DownwardsExtrusion } API_ShellBaseCutBodyTypeID;
Members
- APIShellBaseCutBody_Inside
- Extend roof/shell body for connections: Editable
- APIShellBaseCutBody_ContoursDown
- Extend roof body for connections: Contours down
- APIShellBaseCutBody_PivotLinesDown
- Extend roof body for connections: Pivot Lines down
- APIShellBaseCutBody_UpwardsExtrusion
- Extend shell body for connections: Upwards extrusion
- APIShellBaseCutBody_DownwardsExtrusion
- Extend shell body for connections: Downwards extrusion
Remarks
This enumeration type is used in the API_ShellBaseType structure.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h