API_​ShellBaseSegmentTypeID

Arc decomposition method for polyroof pivot edges or revolved shells. An N integral number tells how many segments to generate and this enum determines how to use the number N.

    typedef enum {
        APIShellBase_SegmentsByCircle,
        APIShellBase_SegmentsByArc
    } API_ShellBaseSegmentTypeID;

 

Members

APIShellBase_SegmentsByCircle
Cut a whole circle to N segments and use as many as necessary to cover the arc.
APIShellBase_SegmentsByArc
Cut the arc itself into N straight segments.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_RoofType, API_PolyRoofData
API_RevolvedShellData, API_PivotPolyEdgeData
API Types