API_​ShellContourData

Shell contour or shell hole contour definition. This structure is used in API_ElementMemo.

    typedef struct {
        API_Polygon             poly;
        API_Coord               **coords;
        Int32                   **pends;
        API_PolyArc             **parcs;
        UInt32                  **vertexIDs;
        UInt32                  **edgeIDs;
        UInt32                  **contourIDs;
        API_ContourEdgeData     *edgeData;
        API_Tranmat             plane;
        double                  height;
        UInt32                  id;
    } API_ShellContourData;

 

Members

poly
The dimensions of the variable size polygon data (see API_Polygon).
coords
Coordinate array.
pends
Polygon endpoints; see API_Polygon for more information.
parcs
Polygon arcs; see API_PolyArc and API_Polygon for more information.
vertexIDs
Unique identifiers the polygon vertices (unique inside the polygon).
edgeIDs
Unique identifiers the polygon edges (unique inside the polygon).
contourIDs
Unique identifiers the polygon contours (unique inside the polygon).
edgeData
Data associated to the edges of the contour polygon (see API_ContourEdgeData).
plane
The contour polygon lies on this plane. The coordinates are given in its 2D coordinate system.
height
Height (depth) of the cutting body extruded from the hole polygon. Always 0 for the outside contour.
id
Id of the hole polygon. Always 0 for the outside contour.

 

Remarks

This structure describes the data for the clipping polygon contour (in this case the height and id members are irrelevant), and the hole contours of a shell element.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_ContourEdgeData, API_Tranmat
ACAPI_Element_GetMemo, API_ElementMemo
Element Manager, API Types