API_​ShellQuantity

Returns the shell quantity values.

    typedef struct {
        double     referenceSurface;
        double     oppositeSurface;
        double     edgeSurface;
        double     referenceSurface_cond;
        double     oppositeSurface_cond;
        double     volume;
        double     volume_cond;
        double     perimeter;
        double     holesSurf;
        double     holesPrm;
        double     grossReferenceSurf;
        double     grossOppositeSurf;
        double     grossEdgeSurf;
        double     grossVolume;
        double     insuThickness;
        double     ridgesLength;
        double     valleysLength;
        double     gablesLength;
        double     hipsLength;
        double     eavesLength;
        double     peaksLength;
        double     sideWallConLength;
        double     endWallConLength;
        double     domeConLength;
        double     hollowConLength;
        double     openingSurf;
        double     floorplanArea;
        Int32      numOfHoles;
        Int32      numOfSkylight;
        Int32      filler_1;
        Int32      filler_2;
    } API_ShellQuantity;

 

Members

referenceSurface
Net area of the reference surface (without holes).
oppositeSurface
Net area of the surface opposite to the reference (without holes).
edgeSurface
Total are of the edges.
referenceSurface_cond
Conditional area of the reference surface.
oppositeSurface_cond
Conditional area of the opposite surface.
volume
Volume of the shell.
volume_cond
Conditional volume of the shell.
perimeter
Perimeter of the contour polygon.
holesSurf
Total area of the holes.
holesPrm
Total perimeter of the holes.
grossReferenceSurf
Gross reference surface area (holes included).
grossOppositeSurf
Gross area of the opposite surface (holes included).
grossEdgeSurf
Gross area of the edge surface.
grossVolume
Gross volume of the shell (holes included).
insuThickness
Insulation thickness of the shell.
ridgesLength
Total length of the ridges.
valleysLength
Total length of the valleys.
gablesLength
Total length of the gables.
hipsLength
Total length of the hips.
eavesLength
Total length of the eaves.
peaksLength
Total length of the peaks.
sideWallConLength
Total length of the connecting line with side walls.
endWallConLength
Total length of the connecting line with wall ends.
domeConLength
Total length of the connecting line with domes.
hollowConLength
Total length of the connecting line with hollows.
openingSurf
Total area of the openings.
floorplanArea
Projected floor plan area of the contour polygon.
numOfHoles
Number of holes in contour polygon.
numOfSkylight
Number of skylight.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API Types