API_​ShellShapeData

Contains the profile data of the Shell element. This structure is used in API_ElementMemo.

    typedef struct {
        API_Coord       **coords;
        Int32           **pends;
        API_PolyArc     **parcs;
        UInt32          **vertexIDs;
        UInt32          **edgeIDs;
        bool            **bodyFlags;
    } API_ShellShapeData;

 

Members

coords
Coordinate array of the shape polyline.
pends
Polyline endpoints; see API_Polygon for more information.
parcs
Polyline arcs; see API_PolyArc and API_Polygon for more information.
vertexIDs
Unique identifiers the polyline vertices (unique inside the polyline).
edgeIDs
Unique identifiers the polyline edges (unique inside the polyline).
bodyFlags
Flags for each edge. If the edge generates a surface (body when applying thickness) it is true. If the edge serves only to close the polyline, it is false. Normally for open polyline profiles all edge flags should be set to true, for closed polyline profiles only the last edge flag should be set to false.

Remarks

Shell shapes are actually polylines with some additional information.

For shell related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_ShellType, API_ExtrudedShellData, API_RevolvedShellData, API_RuledShellData
API_ElementMemo, API_Polygon, API Types