Represents a shell element.
typedef struct { API_Elem_Head head; API_ShellClassID shellClass; Int32 filler_1; API_ShellBaseType shellBase; API_Tranmat basePlane; bool isFlipped; bool hasContour; short filler_2; UInt32 numHoles; API_ShellBaseContourEdgeTypeID defEdgeType; Int32 filler_3; union { API_ExtrudedShellData extrudedShell; API_RevolvedShellData revolvedShell; API_RuledShellData ruledShell; } u; } API_ShellType;
Members
- head
- General element header.
- shellClass
-
API_ShellClassID value Meaning API_ExtrudedShellID
Extruded shell type, use the API_ExtrudedShellData member of the union API_RevolvedShellID
Revolved shell type, use the API_RevolvedShellData member of the union API_RuledShellID
Ruled shell type, use the API_RuledShellData member of the union - shellBase
- Parameters common with all shell-based element types.
- basePlane
- Base plane of the shell element.
- isFlipped
- It tells what way (inside or out) the thickness must be applied from the shell’s surfaces.
- hasContour
- The shell has body contour data. If the shell is cut with a body contour polygon, the data of the contour is stored in the first (0-indexed) record of the
shellContours
array of API_ElementMemo. - numHoles
- Number of the shell hole contours. The data of the hole contours are stored in the
shellContours
array of API_ElementMemo, starting after the body contour if there is one, or from the first record if no body contour is given. - defEdgeType
- Default edge type for the shell element (see API_ShellBaseContourEdgeTypeID).
- u::extrudedShell
- Extruded Shell specific data.
- u::revolvedShell
- Revolved Shell specific data.
- u::ruledShell
- Ruled Shell specific data.
Remarks
For shell related memo data see the ACAPI_Element_GetMemo function.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h
See Also
API_Elem_Head, API_ShellBaseType
API_ExtrudedShellData, API_RevolvedShellData, API_RuledShellData
API_Tranmat, API_ShellBaseContourEdgeTypeID
API_Element, API_ElementMemo
Element Manager, API Types