API_​SideStairStructData

Represents the data of a side supported Stair Structure element.

    typedef struct {
        double                             width;
        double                             heightAboveTread;
        API_StairStructHeightMeasureID     heightMeasure;
        UInt32                             filler_1;
    } API_SideStairStructData;

 

Members

width
The width of the Stair Structure element.
heightAboveTread
The height of the Stair Structure above its related Tread.
heightMeasure
The way of measuring of height above treads:

APIHM_Perpendicular

Perpendicular calculation.

APIHM_Vertical

Straight vertical calculation.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_StairType, API_StairStructureType
Element Manager, API Types