API_​SingleEnumerationVariant

A container for storing a single value from a list of allowed values.

    typedef struct {
        API_Variant                  keyVariant;
        API_Variant                  displayVariant;
        GS::Optional<GS::UniString>  nonLocalizedValue;
    } API_SingleEnumerationVariant;

 

Members

keyVariant API 21
The key that refers to a possible enumeration value of the property definition.
displayVariant API 21
The display value of the variant.
nonLocalizedValue New in API 25
The non-localized value of the variant, if there is one (e.g. in enumeration built-in properties). This value is useful to handle a specific enum value with the same human-readable value in all localized versions.

 

Requirements

Version: API 20 or later
Header: APIdefs_Properties.h

 

See Also

API_PropertyDefinition
API_PropertyValue