API_​SkylightAnchorID

Anchor point of the Skylight object.

    typedef enum {
        APISkylightAnchor_BC,
        APISkylightAnchor_BL,
        APISkylightAnchor_BR,
        APISkylightAnchor_TC,
        APISkylightAnchor_TL,
        APISkylightAnchor_TR
    } API_SkylightAnchorID;

 

Members

APISkylightAnchor_BC
The skylight is anchored by the bottom center position (default).
APISkylightAnchor_BL
The skylight is anchored by the bottom left corner point.
APISkylightAnchor_BR
The skylight is anchored by the bottom right corner point.
APISkylightAnchor_TC
The skylight is anchored by the top center position.
APISkylightAnchor_TL
The skylight is anchored by the top left corner point.
APISkylightAnchor_TR
The skylight is anchored by the top right corner point.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_SkylightType, Element Manager, API Types