API_​SkylightType

Represents a skylight element.

    typedef struct {
        API_Elem_Head             head;
        API_OpeningBaseType       openingBase;
        API_Guid                  owner;
        UInt32                    vertexID;
        API_SkylightFixModeID     fixMode;
        API_SkylightAnchorID      anchorPoint;
        API_Coord                 anchorPosition;
        double                    anchorLevel;
        double                    azimuthAngle;
        double                    elevationAngle;
    } API_SkylightType;

 

Members

head
General element header.
openingBase
Common part of windows, doors and skylights (see API_OpeningBaseType).
owner
Reference to the container roof or shell.
vertexID
For polyroofs it is the ID of the vertex of the pivot polygon. For plane roofs it is always 0.
fixMode
Defines how the skylight is constrained in case the angle or the vertical position of the owner roof or shell changes (see API_SkylightFixModeID).
anchorPosition 17
The point that the position of the skylight object is anchored by (see API_SkylightAnchorID).
anchorPosition
The global XY cooordinate of the anchor point (see fixPoint)
anchorLevel
The global Z coordinate of the anchor point.
azimuthAngle
The rotation angle measured clockwise in the horizontal plane.
elevationAngle
The elevation angle of the roof at the insert position.

Remarks

For skylight related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_OpeningBaseType, API_SkylightFixModeID, API_SkylightAnchorID
API_Element, API_WindowType, API_ElementMemo
Element Manager, API Types