API_​SlabQuantity

Describes the different calculated values for slabs.

    typedef struct {
        double     bottomSurface;
        double     topSurface;
        double     edgeSurface;
        double     bottomSurface_cond;
        double     topSurface_cond;
        double     volume;
        double     volume_cond;
        double     perimeter;
        double     holesSurf;
        double     holesPrm;
        double     grossBotSurf;
        double     grossTopSurf;
        double     grossEdgeSurf;
        double     grossVolume;
        double     grossBotSurfWithHoles;
        double     grossTopSurfWithHoles;
        double     grossEdgeSurfWithHoles;
        double     grossVolumeWithHoles;
        double     filler_1[1];
    } API_SlabQuantity;

 

Members

bottomSurface
bottom surface of the slab
topSurface
top surface of the slab
edgeSurface
surface of the edges of the slab
bottomSurface_cond Changed in API 13
conditional bottom surface of the slab
topSurface_cond Changed in API 13
conditional top surface of the slab
volume
volume of the slab
volume_cond Changed in API 13
conditional volume of the slab
perimeter
perimeter of the slab
holesSurf
total area of holes in the slab
holesPrm
total perimeter of holes in the slab
grossBotSurf
Gross surface of the slab bottom
grossTopSurf
Gross surface of the slab top
grossEdgeSurf
Gross surface of the slab edges
grossVolume
Gross volume of the slab
grossBotSurfWithHoles Changed in API 16
Gross surface of the slab bottom with holes
grossTopSurfWithHoles Changed in API 16
Gross surface of the slab top with holes
grossEdgeSurfWithHoles Changed in API 16
Gross surface of the slab edges with holes
grossVolumeWithHoles Changed in API 16
Gross volume of the slab with holes

 

Remarks

See also the slab parameters for listing in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API_CalcRulesPrefs, API Types