Location of slab’s reference plane.
typedef enum { APISlabRefPlane_Top, APISlabRefPlane_CoreTop, APISlabRefPlane_CoreBottom, APISlabRefPlane_Bottom } API_SlabReferencePlaneLocationID;
Members
- APISlabRefPlane_Top
- Reference plane is the top plane of the slab.
- APISlabRefPlane_CoreTop
- Location of reference plane is the top of the core skin in case of composit slab.
- APISlabRefPlane_CoreBottom
- Location of reference plane is the top of the core skin in case of composit slab.
- APISlabRefPlane_Bottom
- Reference plane is the bottom plane of the slab.
Remarks
The API_SlabReferencePlaneLocationID
enum is used in the API_SlabType structure.
The following picture illustrates the different values:
For a basic (homogenous) slab the possible values are APISlabRefPlane_Top or APISlabRefPlane_Bottom. For composite slabs all values are valid. It determines the reference position: so during input the level member in API_SlabType will refer to this position.
The new offsetFromTop [output only] member tells you the distance of the reference position (level) from the top of the slab.
Requirements
- Version: API 17.0 or later
- Header: APIdefs_Environment.h
See Also
API_Elem_Head, API_Element, API_ElementMemo
API_SlabType
API Types