API_​SlabType

Represents a slab element.

    typedef struct {
        API_Elem_Head                        head;
        short                                pen;
        short                                filler_0;
        API_AttributeIndex                   ltypeInd;
        API_ModelElemStructureType           modelElemStructureType;
        API_AttributeIndex                   buildingMaterial;
        API_AttributeIndex                   composite;
        short                                filler_1;
        short                                sectContPen;
        API_PenOverrideType                  penOverride;
        API_OverriddenAttribute              topMat;
        API_OverriddenAttribute              sideMat;
        API_OverriddenAttribute              botMat;
        bool                                 materialsChained;
        bool                                 filler_2[7];
        double                               thickness;
        double                               level;
        API_AttributeIndex                   hiddenContourLineType;
        short                                hiddenContourLinePen;
        short                                filler_3;
        char                                 filler_4[16];
        bool                                 useFloorFill;
        API_AttributeIndex                   sectContLtype;
        API_SlabReferencePlaneLocationID     referencePlaneLocation;
        short                                filler_5[7];
        API_StoryVisibility                  visibilityCont;
        API_StoryVisibility                  visibilityFill;
        API_LinkToSettings                   linkToSettings;
        short                                floorFillPen;
        short                                floorFillBGPen;
        API_AttributeIndex                   floorFillInd;
        bool                                 use3DHatching;
        bool                                 filler_6[3];
        double                               offsetFromTop;
        API_Polygon                          poly;
        Int32                                filler_7[4];
        API_HatchOrientation                 hatchOrientation;
        short                                filler_8[4];
        bool                                 filler_9[8];
    } API_SlabType;

 

Members

head
General element header.
pen
Pen attribute index of the slab’s contour.
ltypeInd
Line type attribute index of the slab’s contour.
modelElemStructureType Featuring API 17
The structure type of the slab.
buildingMaterial Featuring API 17
Building Material index of slabs’s hatch. Used only, if structure type is API_BasicStrucure.
composite Featuring API 17
Composite index of slab. Used only, if structure type is API_CompositeStructure.
penOverride Featuring API 17
Cut fill pens set in the used structure (building material, composite) can be overridden on the element level.
sectContPen
Contour pen attribute index of the slab’s fill in sections.
topMat Featuring API 17
Top material attribute override structure.
sideMat Featuring API 17
Side material attribute override structure .
botMat Featuring API 17
Bottom material attribute override structure.
materialsChained 20
Are surface materials chained?.
thickness
Thickness of the slab.
level
Distance of the reference level of the slab from the floor level.
hiddenContourLineType Featuring API 23
hiddenContourLinePen Featuring API 23
useFloorFill 6.1
Use cover fill?
sectContLtype 5.1
Line type attribute index of the slab’s section contour.
referencePlaneLocation 5.1
Location of the reference plane.
visibilityCont 6.1
Visibility of slab’s contour line. On the element’s own story the contour should allways be visible.
visibilityFill 6.1
Visibility of slab’s cover fill.
linkToSettings Featuring API 11
Mode of linking to home story.
floorFillPen 6.1
Pen attribute index of slab’s cover fill.
floorFillBGPen 6.1
Background pen attribute index of the slab’s cover fill.
floorFillInd 6.1
Fill attribute index of the slab’s cover fill.
use3DHatching 6.1
Use Vectorial 3D Hatch patterns in Floor Plan view? This will apply the Vectorial 3D Hatch set for the element’s top side material.
offsetFromTop 5.1
Vertical distance between the reference level and the top of the slab (output only), see API_SlabReferencePlaneLocationID.
poly
Polygon of the slab.
hatchOrientation Featuring API 10
Orientation and distortion parameters of the cover fill.

 

Remarks

For slab related memo data see the ACAPI_Element_GetMemo function.

Featuring API 10  In Archicad 10 the useLocalOrigo, locOrigo and fillAngle fields are placed into a separate structure (API_HatchOrientation).

Featuring API 17  In Archicad 17 the type of the elements’ structure is defined with the new modelElemStructureType member. The related attribute indices are separated into buildingMaterial and composite. The composite index is a non-negative index.

Featuring API 17  In Archicad 17 the the elements’ cut fill foreground and background pens inherit from the element structure, and can be overridden on the element level.

Featuring API 17  In Archicad 17 the the elements’ surface materials inherit from the element structure, and can be overridden on the element level.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Elem_Head, API_Element, API_ElementMemo
API_Gable, API_Polygon
API_HatchOrientation, API_StoryVisibility, API_LinkToSettings
Element Manager, API Types