The type of the solid operation link between two construction elements.
typedef enum { APISolid_Substract = 'SSUB',, APISolid_SubstUp = 'SSUU',, APISolid_SubstDown = 'SSUD',, APISolid_Intersect = 'SINT',, APISolid_Add = 'SADD' } API_SolidOperationID;
Members
- APISolid_Substract
- Substraction
- APISolid_SubstUp
- Substraction with upwards extrusion
- APISolid_SubstDown
- Substraction with downwards extrusion
- APISolid_Intersect
- Intersection
- APISolid_Add
- Addition
Remarks
These enumerators are used with the ACAPI_Element_SolidLink_Create, ACAPI_Element_SolidLink_GetOperation and ACAPI_Element_SolidOperation_Create functions.
Requirements
- Version: API 4.2 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidOperation_Create
API Types