API_​SpecFolderID

The selector of special folders.

    typedef enum {
        API_ApplicationPrefsFolderID,
        API_GraphisoftPrefsFolderID,
        API_GraphisoftHomeFolderID,
        API_CacheFolderID,
        API_DataFolderID,
        API_UserDocumentsFolderID,
        API_TemporaryFolderID,
        API_ApplicationFolderID,
        API_DefaultsFolderID,
        API_WebObjectsFolderID,
        API_TemplatesFolderID,
        API_HelpFolderID,
        API_EmbeddedProjectLibraryFolderID,
        API_EmbeddedProjectLibraryHotlinkFolderID
    } API_SpecFolderID;

 

Members

API_ApplicationPrefsFolderID
The folder into which the application writes its preferences.
API_GraphisoftPrefsFolderID
The folder containing general preferences of Graphisoft applications.
API_GraphisoftHomeFolder
The Graphisoft home folder.
API_CacheFolder
The folder where the application may write data to speed up its operation.
API_DataFolderID 17
The location of the Data folder.
API_UserDocumentsFolder
The folder where the application places the output files by default.
API_TemporaryFolder
The folder where the application stores temporary data, and which will be emptied when you launch the application.
API_ApplicationFolderID 4.2
The folder containing the running application. It should be considered as read-only.
API_DefaultsFolderID 6.1
This folder contains the default preferences (e.g. default user profile settings, shortcuts, command layouts, etc.) that come with the program installation. Located in the application folder, and should be considered as read-only.
API_WebObjectsFolderID 6.1
This folder is the recommended place for storing objects and other files downloaded from the Web.
API_TemplatesFolderID 6.1
The default location of Archicad project templates.
API_HelpFolderID 10
The default location of the application’s Help folder.
API_EmbeddedProjectLibraryFolderID 13
The location of the embedded project library.
API_EmbeddedProjectLibraryHotlinkFolderID 15
The location of the embedded project library of hotlinked modules.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetSpecFolderID
API Types