API_​SplineDir

Describes the control handles for Bezier-splines.

    typedef struct {
        double     lenPrev;
        double     lenNext;
        double     dirAng;
    } API_SplineDir;

 

Members

lenPrev
Bezier direction length previous.
lenNext
Bezier direction length next.
dirAng
Bezier direction angle.

 

Remarks

The picture below illustrates the meaning of these fields.

Spline dir

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_SplineType, API_ElementMemo, API Types