API_​StairBoundaryData

Represents a Stair boundary.

    typedef struct {
        API_Polygon                     polygon;
        API_Coord                       **coords;
        Int32                           **pends;
        API_PolyArc                     **parcs;
        API_StairBoundaryEdgeData       *edgeData;
        API_StairBoundaryVertexData     *vertexData;
        bool                            isCustom;
        bool                            filler_1[7];
    } API_StairBoundaryData;

 

Members

polygon
The API polygon element describing the amounts of vertices in the boundary line.
coords
The coordinates of the vertices of the boundary line.
pends
The polygon endings of the boundary line.
parcs
The arcs of the boundary line.
edgeData
The edge data of each edge.
vertexData
The vertex data of each vertex.
isCustom
True, if the stair boundary is customized.

 

Remarks

There are two Stair boundaries in the API_ElementMemo structure, the one with the index of 0 describes the left, and the one with the index of 1 describes the right side boundary line of the Stair element.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_StairBoundaryVertexData, API_StairBoundaryEdgeData, API_Polygon, API_PolyArc, API_Coord
API_ElementMemo
API_StairType, API_StairTreadType, API_StairStructureType, API_StairRulesData
Element Manager, API Types