API_​StairBoundaryEdgeData

Stores data of a stair boundary edge.

    typedef struct {
        API_StairPolyTypeID             type;
        API_StairPolyGeometryTypeID     geometryType;
        UInt32                          subElemId;
        bool                            isTop;
        bool                            isBottom;
        bool                            isFront;
        bool                            isBack;
        UInt32                          customId;
        bool                            visible;
        bool                            filler_1[3];
    } API_StairBoundaryEdgeData;

 

Members

type
The type of the boundary polyline section.
geometryType
The geometry type of the boundary polyline section.
subElemId
The subelement identifier of the boundary polyline section.
isTop
The section describes the top of the subelement.
isBottom
The section describes the bottom of the subelement.
isFront
The section describes the front of the subelement.
isBack
The section describes the back of the subelement.
customId
Internal identifier.
visible
The described subelement is visible.

 

Remarks

 

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_StairBoundaryData, API_StairPolyTypeID, API_StairPolyGeometryTypeID
API_ElementMemo
API_StairType, API_StairTreadType, API_StairStructureType, API_StairRulesData
Element Manager, API Types