API_​StairLayoutData

Represents the layout of a Stair element.

    typedef struct {
        API_StoryVisibility             visibility;
        bool                            isAutoOnStoryVisibility;
        bool                            filler_1[3];
        API_StairGridTypeID             gridTypeAbove;
        API_StairGridTypeID             gridTypeTop;
        API_StairGridTypeID             gridTypeMiddle;
        API_StairGridTypeID             gridTypeBottom;
        API_StairGridTypeID             gridTypeBelow;
        API_StairStoryVisibilityID      storyVisibility;
        bool                            showWalkingLine;
        bool                            showNumbering;
        bool                            showUpDownText;
        bool                            showDescription;
        bool                            filler_2[2];
        bool                            showStructure;
        bool                            filler_3[5];
        double                          breakLineAngle;
        Int32                           breakLineAngleNumberOfGoings;
        API_BreakLineAngleTypeID        breakLineAngleType;
        double                          breakLineDistance;
        API_BreakLinePositionTypeID     breakLinePositionType;
        Int32                           filler_4;
        double                          upperBreakLineCustomPosition;
        double                          lowerBreakLineCustomPosition;
        UInt32                          upperBreakLineNthRiserPosition;
        UInt32                          lowerBreakLineNthRiserPosition;
        bool                            overrideLineType;
        bool                            overridePen;
        short                           pen;
        API_AttributeIndex              lineType;
        bool                            overrideSymbolFill;
        bool                            filler_5[3];
        API_AttributeIndex              symbolFill;
        short                           symbolFillPen;
        short                           symbolFillBkgPen;
        short                           filler_6[2];
    } API_StairLayoutData;

 

Members

visibility
The option to define on which stories are the stairs displayed.
isAutoOnStoryVisibility
It will be true, if showOnHome in visibility is false.
gridTypeAbove
Layout above relevant stories:

APIStairGrid_NotRelevant

Not Relevant.

APIStairGrid_WithSingleBreaklineFull

With Break Mark: Visible – Hidden

APIStairGrid_NoBreaklineFull

No Break Mark: Visible

APIStairGrid_BelowBreakline

Below Break Mark: Visible

APIStairGrid_AboveBreakline

Above Break Mark: Visible

APIStairGrid_MiddleBreakline

Multistory 2D: Visible Inbetween Break Marks

APIStairGrid_MiddleBreaklineFull

Multistory 2D: Hidden – Visible – Hidden

APIStairGrid_NoBreakMarkHidden

No Break Mark: Hidden

APIStairGrid_AboveBreakMarkHidden

Above Break Mark: Hidden

APIStairGrid_BelowBreakMarkHidden

Below Break Mark: Hidden

APIStairGrid_Multistory2DAllVisible

Multistory 2D: All Visible

APIStairGrid_Multistory2DHiddenVisible

Multistory 2D: Hidden – Visible – None

APIStairGrid_Multistory2DNoneVisibleHidden

Multistory 2D: None – Visible – Hidden

APIStairGrid_WithBreakMarkAllVisible

With Break Mark: All Visible

APIStairGrid_WithBreakMarkHiddenVisible

With Break Mark: Hidden – Visible

gridTypeTop
Layout on top relevant stories.
gridTypeMiddle
Layout on middle stories.
gridTypeBottom
Layout on bottom story.
gridTypeBelow
Layout below relevant stories.
showWalkingLine
If true, the walking line is shown.
showNumbering
If true, the stair numbering is shown.
showUpDownText
If true, the stair direction label is shown.
showDescription
If true, the stair description is shown.
showStructure
If true, the stair structures are shown.
breakLineAngle
The angle of the break line.
breakLineAngleNumberOfGoings
The amount of goings of the break line.
breakLineAngleType
The angle type of the break line:

APIBreakLineAngle_AngleToVertical

Angel to vertical.

APIBreakLineAngle_AngleToHorizontal

Angle to horizontal.

APIBreakLineAngle_NumberOfGoings

Angle will be calculated based on the given Number of Goings.

breakLineDistance
The gap of the break line.
breakLinePositionType
The line position type of the break line:

APIBreakLinePosition_FloorPlanCutPlaneHeight

Break line height is determined from the Floor Plan Cut Plane Height.

APIBreakLinePosition_CustomHeight

Break line is on Custom Height.

APIBreakLinePosition_AtNthRiser

Break line is on a given Riser.

upperBreakLineCustomPosition
Custom position of the upper break line.
lowerBreakLineCustomPosition
Custom position of the lower break line.
upperBreakLineNthRiserPosition
Riser position of the upper break line.
lowerBreakLineNthRiserPosition
Riser position of the lower break line.
overrideLineType
If true, the line type will be overridden.
overridePen
If true, the line pen will be overridden.
lineType
The line type index for the Stair.
pen
The line pen index for the Stair.
overrideSymbolFill
If true, the fill will be overridden.
symbolFill
The symbol fill type index for the Stair.
symbolFillPen
The sybol fill pen index for the Stair.
symbolFillBkgPen
The symbol fill background pen index for the Stair.

 

Remarks

The Stair is a hierarchical (system) element consisting of Tread, Riser, and Structure components: these are the members of the Stair, arranged on a base surface according to a pre-defined scheme.

To create a Stair, one must provide its base line and position.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex
API_StoryVisibility
API_StairType
Element Manager, API Types