Determines the type of a Stair boundary edge or vertex.
typedef enum { APISG_Vertex, APISG_Edge, APISG_Surface } API_StairPolyGeometryTypeID;
Members
- APISG_Vertex
- The described polyline section is a vertex.
- APISG_Edge
- The described polyline section is an edge.
- APISG_Surface
- The described polyline section is a surface.
Remarks
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_StairBoundaryVertexData, API_StairBoundaryEdgeData
Element Manager, API Types