Represents a Stair polyline (baseline or walking line).
typedef struct { API_Polygon polygon; API_Coord **coords; Int32 **pends; API_PolyArc **parcs; API_StairPolylineEdgeData *edgeData; API_StairPolylineVertexData *vertexData; } API_StairPolylineData;
Members
- polygon
- The API polygon element describing the amounts of vertices in the boundary line.
- coords
- The coordinates of the vertices of the boundary line.
- pends
- The polygon endings of the boundary line.
- parcs
- The arcs of the boundary line.
- edgeData
- The edge data of each edge.
- vertexData
- The vertex data of each vertex.
Remarks
There are two Stair polylines in the API_StairType structure, the baseline and the walking line.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_StairPolylineVertexData, API_StairPolylineEdgeData, API_Polygon, API_PolyArc, API_Coord
API_StairType
Element Manager, API Types