API_​StairPolylineEdgeData

Stores data of a stair polyline edge.

    typedef struct {
        API_StairPolyTypeID             type;
        API_StairPolyGeometryTypeID     geometryType;
        UInt32                          subElemId;
        bool                            isTop;
        bool                            isBottom;
        bool                            isFront;
        bool                            isBack;
        UInt32                          customId;
        API_StairSegmentTypeID          segmentType;
        bool                            isLocked;
        bool                            filler_1[3];
        Int32                           filler_2;
    } API_StairPolylineEdgeData;

 

Members

type
The type of the boundary polyline section.
geometryType
The geometry type of the boundary polyline section.
subElemId
The subelement identifier of the boundary polyline section.
isTop
The section describes the top of the subelement.
isBottom
The section describes the bottom of the subelement.
isFront
The section describes the front of the subelement.
isBack
The section describes the back of the subelement.
customId
Internal identifier.
segmentType
Type of the segment described by this edge:

APIST_StepsSegment

Step segment.

APIST_LandingSegment

Landing segment.

APIST_DividedLandingSegment

Divided landing segment.

isLocked
If true, edge is locked.

 

Remarks

 

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_StairPolylineData, API_StairPolyTypeID, API_StairPolyGeometryTypeID
API_ElementMemo
Element Manager, API Types