Stores data of a stair polyline vertex.
typedef struct { API_StairPolyTypeID type; API_StairPolyGeometryTypeID geometryType; UInt32 subElemId; bool isTop; bool isBottom; bool isFront; bool isBack; UInt32 customId; API_StairTurnTypeID turnType; Int32 winderStepNumBackward; Int32 winderStepNumForward; bool symmetricalLandingOffset; bool filler_1[7]; double minLandingStartEdgeOffset; double minLandingEndEdgeOffset; double currLandingStartEdgeOffset; double currLandingEndEdgeOffset; double filler_2; API_StairInnerWidthOffsetTypeID innerWidthOffsetType; API_StairWinderNumTypeID numOfWindersType; API_StairDLWinderNumTypeID dividedLandingNumOfWindersType; Int32 dividedLandingFixedNumOfSteps; API_StairWinderID winderType; } API_StairPolylineVertexData;
Members
- type
- The type of the boundary polyline section.
- geometryType
- The geometry type of the boundary polyline section.
- subElemId
- The subelement identifier of the boundary polyline section.
- isTop
- The section describes the top of the subelement.
- isBottom
- The section describes the bottom of the subelement.
- isFront
- The section describes the front of the subelement.
- isBack
- The section describes the back of the subelement.
- customId
- Internal identifier.
- turnType
-
The type of the turn.
APIST_NoTurn
No turn.
APIST_LandingTurn
Type is landing turn.
APIST_WinderTurn
Type is winder turn.
APIST_DividedLandingTurn
Type is divided landing turn.
- winderStepNumBackward
- Number of Winder Steps backward.
- winderStepNumForward
- Number of Winder Steps forward.
- symmetricalLandingOffset
- Lead Edge Offset and Trail Edge Offset are linked.
- minLandingStartEdgeOffset
- Minimal Lead Edge Offset.
- minLandingEndEdgeOffset
- Minimal Trail Edge Offset.
- currLandingStartEdgeOffset
- Calculated Lead Edge Offset.
- currLandingEndEdgeOffset
- Calculated Trail Edge Offset.
- minWinderTurnOffset
- UNUSED PARAMETER
- innerWidthOffsetType
-
The type of the Riser Offsets from Corner:
APIIWO_Min
Minimum Riser Offset.
APIIWO_Fix
Fixed Riser Offset.
- numOfWindersType
-
The type of the Number of Winders:
APIWN_Min
Minimum Number of Winders.
APIWN_Fix
Fixed Number of Winders.
- dividedLandingNumOfWindersType
- Winders division method type.
- dividedLandingFixedNumOfSteps
- Number of steps on Divided Landing if the division method is Fixed Number of Goings.
- winderType
-
The type of the Winder:
APIWT_DINTurn
Auxiliary Walking Line
APIWT_NZETurn
Two Points
APIWT_SIPTurn
Single Point
APIWT_AGNTurn
Principal Lines
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_StairBoundaryData, API_StairPolyTypeID, API_StairPolyGeometryTypeID
API_ElementMemo
API_StairType, API_StairTreadType, API_StairStructureType, API_StairRulesData
Element Manager, API Types