API_​StairPolyTypeID

Determines the type of a Stair boundary edge or vertex.

    typedef enum {
        APISP_Undefined,
        APISP_BaseLine,
        APISP_LeftBoundary,
        APISP_RightBoundary,
        APISP_Tread,
        APISP_Riser,
        APISP_WalkingLine,
        APISP_FloorPlanSymb,
        APISP_BreakMark,
        APISP_DummyTreadLeading,
        APISP_DummyTreadTrailing
    } API_StairPolyTypeID;

 

Members

APISP_Undefined
The type is undefined.
APISP_BaseLine
The type is baseline.
APISP_LeftBoundary
The type is left boundary.
APISP_RightBoundary
The type is right boundary.
APISP_Tread
The type is tread.
APISP_Riser
The type is riser.
APISP_WalkingLine
The type is walking line.
APISP_FloorPlanSymb
The type is floor plan symb.
APISP_BreakMark
The type is break mark.
APISP_DummyTreadLeading
The type is dummy tread leading.
APISP_DummyTreadTrailing
The type is dummy tread trailing.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_StairBoundaryVertexData, API_StairBoundaryEdgeData
Element Manager, API Types