API_​StairQuantity

Calculates values for stairs.

    typedef struct {
        double     area;
        double     volume;
        double     height;
        double     walklineLength;
        double     gradient;
        Int32      numOfRisers;
        Int32      numOfTreads;
    } API_StairQuantity;

 

Members

area
The front surface area of the stair.
volume
Volume of the stair.
height
Height of the stair.
walklineLength
Length of the stair’s walking line .
gradient
Inclination angle of the stair.
numOfRisers
Number of risers in this stair.
numOfTreads
Number of treads in this stair.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API Types