Represents a the Rules and Standards of a Stair element.
typedef struct { double riserHeightMinValue; double riserHeightMaxValue; double treadDepthMinValue; double treadDepthMaxValue; double ruleMinValue; double ruleMaxValue; double landingLengthMinValue; double walkingLineOffsetMinValue; double winderTurnOffsetMinValue; double riserGoingRatioMinValue; double riserGoingRatioMaxValue; double riserPlusGoingMinValue; double riserPlusGoingMaxValue; double stairPitchMinValue; double stairPitchMaxValue; bool riserHeightMinApplied; bool riserHeightMaxApplied; bool treadDepthMinApplied; bool treadDepthMaxApplied; bool ruleMinApplied; bool ruleMaxApplied; bool landingLengthMinApplied; bool walkingLineOffsetMinApplied; bool winderTurnOffsetMinApplied; bool filler_1[2]; bool riserGoingRatioMinApplied; bool riserGoingRatioMaxApplied; bool riserPlusGoingMinApplied; bool riserPlusGoingMaxApplied; bool stairPitchMinApplied; bool stairPitchMaxApplied; bool filler_2[3]; } API_StairRulesData;
Members
- riserHeightMinValue
- Minimum riser height.
- riserHeightMaxValue
- Maximum riser height.
- treadDepthMinValue
- Minimum going length.
- treadDepthMaxValue
- Maximum going length.
- ruleMinValue
- Minimum 2R+G.
- ruleMaxValue
- Maixmum 2R+G.
- landingLengthMinValue
- Minimum automatic landing length.
- walkingLineOffsetMinValue
- Minimum automatic landing offset.
- winderTurnOffsetMinValue
- Minimum winder width.
- riserGoingRatioMinValue
- Minimum riser height/tread length ratio.
- riserGoingRatioMaxValue
- Maximum riser height/tread length ratio.
- riserPlusGoingMinValue
- Minimum riser height + tread length value.
- riserPlusGoingMaxValue
- Maximum riser height + tread length value.
- stairPitchMinValue
- Minimum stair pitch.
- stairPitchMaxValue
- Maximum stair pitch.
- riserHeightMinApplied
- Minimum riser height set.
- riserHeightMaxApplied
- Maximum riser height set.
- treadDepthMinApplied
- Minimum going length set.
- treadDepthMaxApplied
- Maximum going length set.
- ruleMinApplied
- Minimum 2R+G set.
- ruleMaxApplied
- Maixmum 2R+G set.
- landingLengthMinApplied
- Minimum automatic landing length set.
- walkingLineOffsetMinApplied
- Minimum automatic landing offset set.
- winderTurnOffsetMinApplied
- Minimum winder width set.
- riserGoingRatioMinApplied
- Minimum riser height/tread length ratio set.
- riserGoingRatioMaxApplied
- Maximum riser height/tread length ratio set.
- riserPlusGoingMinApplied
- Minimum riser height + tread length value set.
- riserPlusGoingMaxApplied
- Maximum riser height + tread length value set.
- stairPitchMinApplied
- Minimum stair pitch set.
- stairPitchMaxApplied
- Maximum stair pitch set.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_StairTreadType, API_StairRiserType, API_StairStructureType, API_StairType
Element Manager, API Types