API_​StairStructureDrainingData

Represents the draining of a monolithic Stair Structure element.

    typedef struct {
        bool                            enabled;
        bool                            filler_1[7];
        double                          width;
        double                          offset;
        double                          horizontalDepth;
        double                          verticalDepth;
        API_OverriddenAttribute         material;
        API_StairDrainSurfaceTypeID     surfaceType;
    } API_StairStructureDrainingData;

 

Members

enabled
True, if structure draining is enabled.
width
Width of the draining.
offset
Offset from boundary.
horizontalDepth
Draining vertical depth.
verticalDepth
Draning horizontal depth.
material
Material of the draining.
surfaceType
Surface type of the draining:

APIST_Stepped

Stepped structure draining.

APIST_Smooth

Smooth structure draining.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element
Element Manager, API Types