Represents the data of a 2D symbol a Stair’s Structure elements.
typedef struct { API_AttributeIndex visibleLineType; short visibleLinePen; short hiddenLinePen; API_AttributeIndex hiddenLineType; API_AttributeIndex visibleFillType; short visibleFillPen; short visibleFillBackgroundPen; API_AttributeIndex hiddenFillType; short hiddenFillPen; short hiddenFillBackgroundPen; bool filler_1[4]; } API_StairStructureSymbolData;
Members
- visibleLineType
- Type of the visible lines.
- visibleLinePen
- Pen of the visible lines.
- hiddenLineType
- Type of the hidden lines.
- hiddenLinePen
- Pen of the hidden lines.
- visibleFillType
- Type of the visible fills.
- visibleFillPen
- Pen of the visible fills.
- visibleFillBackgroundPen
- Pen of the visible background fills.
- hiddenFillType
- Type of the hidden fills.
- hiddenFillPen
- Pen of the hidden fills.
- hiddenFillBackgroundPen
- Pen of the hidden background fills.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_AttributeIndex
API_StairType,
Element Manager,
API Types