Represents a Stair Structure element.
typedef struct { API_Elem_Head head; API_Guid owner; API_Guid libId; GS::UInt32 sequenceNumber; GS::UInt32 subElemId; bool visible; bool isLanding; short filler_1[3]; API_StairStructureTypeID structType; API_StairStructBottomTypeID bottomType; double horizontalThickness; double thickness; union { API_SideStairStructData sideStair; API_MonolithStairStructData monolith; } data; API_StairPartRoleID role; API_StairStructureSideID side; } API_StairStructureType;
Members
- head
- General element header.
- owner
- GUID of the owning stair.
- libId
- Library part GUID.
- sequenceNumber
- The number of the step that the structure element belongs to.
- subElemId
- The subelement identifier of the structure element.
- visible
- True, if the object is visible.
- isLanding
- True, if the structure is a landing.
- structType
-
The type of the stair structure:
APIST_Side
The Stair is supported at its sides.
APIST_Monolith
The Stair has a solid block under it.
APIST_BeamSupport
The Stair is supported by beams.
APIST_CantileveredSupport
The Stair is supported at only one side.
- bottomType
-
The type of the stair structure bottom:
APISB_Stepped
The stair structure is stepped along with the steps.
APISB_Flat
The stair structure is flattened under the steps.
APISB_Smooth
The stair structure is monolithic.
- horizontalThickness
- The horizontal thickness of the stair structure.
- thickness
- The thickness of the stair structure.
- sideStair
- Data of the side supported structures.
- monolith
- Data of the monolithic structures.
- role
- Role of the Stair subelement.
- side
-
Supported side of the Stair:
APISS_LeftSide
The stair structure supports the step from the left side.
APISS_RightSide
The stair structure supports the step from the right side.
APISS_UnderSide
The stair structure supports the step from under.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_LinkToSettings, API_StoryVisibility, API_PolyLineType
API_Elem_Head, API_Element, API_ElementMemo
API_StairType, API_StairRiserType, API_StairTreadType, API_StairRulesData
Element Manager, API Types