API_​StairTreadQuantity

Calculated values for a stair tread.

    typedef struct {
        double     area;
        double     volume;
        double     thickness;
        double     elevation;
        Int32      stepIndex;
        Int32      filler;
    } API_StairTreadQuantity;

 

Members

area
Top surface area of the given tread.
volume
Volume of the given tread.
thickness
Thickness of the given tread.
elevation
Elevation to project zero.
stepIndex
Step index of the given tread.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API Types