API_​StairTreadType

Represents a Tread element.

    typedef struct {
        API_Elem_Head                  head;
        bool                           isCustom;
        bool                           visible;
        bool                           filler_1[2];
        API_StairTreadNosingTypeID     nosingType;
        double                         nosingValue;
        double                         nosingSlant;
        double                         offset;
        double                         thickness;
        API_Guid                       owner;
        API_Guid                       libId;
        UInt32                         sequenceNumber;
        UInt32                         subElemId;
        double                         zOffset;
        API_StairPartRoleID            role;
        bool                           filler_2[4];
    } API_StairTreadType;

 

Members

head
General element header.
isCustom
Tread is custom.
visible
The object is visible.
nosingType
Type of the Tread nosing:

APITN_ByValue

The Tread nosing is given a length value.

APITN_BySlanting

The Tread nosing is given a slanting value.

nosingValue
Length of the nosing if the nosing type is by value.
nosingSlant
Slanting of the nosing if the nosing type is by slanting.
offset
Tread gap.
thickness
Tread thickness.
owner
GUID of the owning stair.
libId
Library part GUID.
sequenceNumber
The number of the step that the tread belongs to.
subElemId
The subelement identifier of the tread.
zOffset
The custom offset of the tread.
role
Role of the Stair subelement.

 

Remarks

 

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_LinkToSettings, API_StoryVisibility, API_PolyLineType
API_Elem_Head, API_Element, API_ElementMemo
API_StairType, API_StairRiserType, API_StairStructureType, API_StairRulesData
Element Manager, API Types