Represents a Stair element.
typedef struct { API_Elem_Head head; double totalHeight; double topOffset; API_LinkToSettings linkToSettings; short relativeTopStory; short filler_1; double flightWidth; UInt32 stepNum; UInt32 nFPDMarkers; UInt32 nRCPDMarkers; UInt32 treadNum; double riserHeight; UInt32 treadDepth; bool treadDepthLocked; bool totalHeightLocked; short filler_2; double walkingLineOffset; API_LinePositionID walkingLinePosition; bool extraTopTread; bool extraBottomTread; bool finishVisible; API_LinePositionID baselinePosition; double baselineOffset; API_StairRulesData rules; API_StairTreadType tread[API_StairPartRoleNum]; API_StairRiserType riser[API_StairPartRoleNum]; API_StairStructureType structure[API_StairPartRoleNum][API_StairStructureSideNum]; API_StairDisplayTypeID stairDisplayType; API_StairLayoutData fpdLayout; API_StairLayoutData rcpdLayout; API_StairNumberingID numberingType; API_StairDirectionID inputDirection; API_Plane3D basePlane; bool uniformFinish; bool uniformMonolithAttributes; bool uniformLeftRightSideSupports[API_StairPartRoleNum]; bool uniformDrainings; bool structureVisibility; bool filler_3[6]; API_StairStructureSymbolData structSymbData[API_StairStructSymbTypeNum][API_StairStructSymbViewNum]; API_StairMonolithStructureSymbolData monolithStructureSymbolData[API_StairStructSymbViewNum][API_StairStructSymbPartNum]; API_StairStructureComponentSettingsVisibility structureVisibilityOnStories[API_StairStructSymbViewNum]; API_StairWalkLineSymbPosID walkLineSymbPos; API_StairHeadroomData stairHeadroomData; } API_StairType;
Members
- head
- General element header.
- totalHeight
- The height of the stairs relative to their bottom.
- topOffset
- The offset from top floor if the stairs are top linked.
- linkToSettings
- Mode of linking to home story.
- relativeTopStory
- The top linked story (relative to home story).
- flightWidth
- The width of the stairs.
- stepNum
- The number of steps (risers).
- nFPDMarkers
- The amount of markers associated to the Stair element on the Floor Plan display.
- nRCPDMarkers
- The amount of markers associated to the Stair element on the Reflected Ceilind Plan display.
- treadNum
- The number of treads in this stair.
- riserHeight
- The height of each riser.
- treadDepth
- The length of each going.
- treadDepthLocked
- Going lengths are locked.
- totalHeightLocked
- The total height of the Stair is locked.
- walkingLinePosition
-
Position of the walking line:
APILP_Left
Offset from the left side.
APILP_Right
Offset from the right side.
APILP_Center
Centered.
APILP_Auto
Automatic (walking lines only).
- walkingLineOffset
- Offset of the walking line, if not centered.
- baselineOffset
- Offset of the baseline, if not centered.
- baselinePosition
- Position of the baseline.
- rules
- The rules and standards of the stairs.
- tread
- Default parameters of treads.
- riser
- Default parameters of risers.
- structure
- Default parameters of the stair structure.
- stairDisplayType
-
Display type of the Stair:
APIStairDisplay_Custom
Custom display.
APIStairDisplay_ByModelViewOptions
Display by Model View Options.
- fpdLayout
- The layout of the Stair element in Floor Plan Display.
- rcpdLayout
- The layout of the Stair element in Reflected Ceiling Plan Display.
- numberingType
-
Type of numbering for each step of the Stair element:
APISN_Treads
Numbering on treads.
APISN_Risers
Numbering on risers.
- inputDirection
-
The walking direction of the Stair element:
APISD_Upward
Default walking direction (upwards).
APISD_Inverse
Inverse walking direction (downwards).
- basePlane
- The base plane of the Stair subelements.
- uniformFinish
- Uniform Finish on Flight and Landing.
- uniformMonolithAttributes
- Uniform Monolithic on Flight and Landing.
- uniformLeftRightSideSupports
- Uniform Stringers on Left and Right.
- uniformDrainings
- Uniform Drainings on Flight and Landing
- structureVisibility
- The Structure is visible.
- structSymbData
- Stair Structure symbol data for 2D representations.
- monolithStructureSymbolData
- Monolith stair structure symbol data for 2D representations.
- structureVisibilityOnStories
- Stair Structure symbol visibility for 2D representations.
- walkLineSymbPos
-
Position of the walking line symbol:
APISP_Auto
Automatic positioning.
APISP_Center
Centered positioning.
APISP_Custom
Custom positioning.
- stairHeadroomData
- Data of the headroom.
Remarks
The Stair is a hierarchical element consisting of Tread, Riser, and Structure components: these are the members of the Stair, arranged on a base surface according to a pre-defined scheme.
To create a Stair, one must provide its base line and position.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_LinkToSettings, API_StoryVisibility, API_PolyLineType
API_Elem_Head, API_Element, API_ElementMemo
API_StairTreadType, API_StairRiserType, API_StairStructureType, API_StairRulesData, API_StairBoundaryData
Element Manager, API Types